[alsa-devel] Regression post-ALSA 1.0.22 for Lenovo G555 Internal mic

Takashi Iwai tiwai at suse.de
Mon May 23 21:23:04 CEST 2011

At Mon, 23 May 2011 18:07:09 +0100,
Roo - Andrew Baines wrote:
> I have tried the latest snapshot, and placed "options snd-hda-intel
> model=auto" in /etc/modprobe.d/alsa-base.conf
> Still no sound into the mic, although sometimes when I open "PulseAudio
> Volume Meter (Capture)" it now shows a lot of noise for about half a second
> before nothing.
> Also, I used to have to put "/usr/local/bin/hda-verb /dev/snd/hwC0D0 0x19
> SET_PIN_WIDGET_CONTROL 0x40" in /etc/rc.local to turn on the headphone
> socket at boot, but this happens by itself now. The problem is that the
> daemon "pinsensed<http://ubuntuforums.org/showpost.php?p=9599525&postcount=152>"
> I was using no longer mutes the speakers when the headphones are plugged in.

The driver should do auto-muting without such a daemon.  If it still
doesn't, check whether the unsolicited event is triggered at plugging
by adding some debug prints.

> I have attached the new alsa-info.sh output (I hope attachments are allowed
> on the mailing list)

I fixed a couple of obvious bugs now.
Please try alsa-driver snapshot again later with model=auto.



More information about the Alsa-devel mailing list