[alsa-devel] Regression post-ALSA 1.0.22 for Lenovo G555 Internal mic

Roo - Andrew Baines andrewmbaines at gmail.com
Mon May 23 19:07:09 CEST 2011

I have tried the latest snapshot, and placed "options snd-hda-intel
model=auto" in /etc/modprobe.d/alsa-base.conf

Still no sound into the mic, although sometimes when I open "PulseAudio
Volume Meter (Capture)" it now shows a lot of noise for about half a second
before nothing.

Also, I used to have to put "/usr/local/bin/hda-verb /dev/snd/hwC0D0 0x19
SET_PIN_WIDGET_CONTROL 0x40" in /etc/rc.local to turn on the headphone
socket at boot, but this happens by itself now. The problem is that the
daemon "pinsensed<http://ubuntuforums.org/showpost.php?p=9599525&postcount=152>"
I was using no longer mutes the speakers when the headphones are plugged in.

I have attached the new alsa-info.sh output (I hope attachments are allowed
on the mailing list)


On 23 May 2011 17:14, Takashi Iwai <tiwai at suse.de> wrote:

> At Mon, 23 May 2011 16:58:39 +0100,
> Roo - Andrew Baines wrote:
> >
> > Dear All,
> >
> > I have been told I should send an email to this list from this
> > bug<https://bugtrack.alsa-project.org/alsa-bug/view.php?id=5367>
> >  (0005367).
> >
> > There is a regression in ALSA 1.0.23 and above for Lenovo sound. The
> > internal mic no longer works. A helpful guy 'Raymond' on the bug
> identified
> > that pin-ctls is correct in ALSA 1.0.21 and 1.0.22, but incorrect in
> higher
> > versions due to SND_PCI_QUIRK_VENDOR. This is based on alsa-info.sh run
> on
> > systems using different versions of ALSA but on the same system.
> >
> > The jacksense has never actually worked but I have always managed to use
> > hda-verb to do this for me - the main issue is the regression with the
> > internal mic.
> Try the latest alsa-driver snapshot from
> ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/snapshot/alsa-driver-snapshot.tar.gz
> and pass model=auto.  If this doesn't work, please give alsa-info.sh
> output at this state.
> thanks,
> Takashi
-------------- next part --------------
A non-text attachment was scrubbed...
Name: alsa-info.txt.AU7uf2wPsZ
Type: application/octet-stream
Size: 18602 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20110523/2d3098de/attachment-0001.dll 

More information about the Alsa-devel mailing list