[alsa-devel] Hammerfall hdsploader not working in ubuntu 8.10

Tim Blechmann tim at klingt.org
Fri Feb 20 16:08:41 CET 2009

hi robert,

> i'm using a rme Hammerfall hdsp multiface card which i've never had 
> problems so far, due to
> the fact that it's pretty well supported.
> However, after upgrading to Ubuntu 8.10 the hdsploader fails to upload 
> the firmware to the card with the
> following error:
> hdsploader - firmware loader for RME Hammerfall DSP cards
> Looking for HDSP + Multiface or Digiface cards :
> Card 0 : RME Hammerfall DSP + Multiface at 0xf87f0000, irq 22
> Upload firmware for card hw:0
> Hwdep ioctl error on card hw:0 : Device or resource busy.

i did experience some `strange' behavior on my hdsp as well, starting a
few months ago.
in my case, the hdsp tells me, that the io box is not connected. my
workaround was to unload/reload the module.
maybe related to that issue, sometimes, the hdspmixer doesn't read the
meter values from the interface, giving me the same `hwdep ioctl error',
you are experiencing with hdsploader (i don't use hdsploader, since it
is basically obsolete).

i suppose, it is a similar issue, that i am experiencing ... btw are you
running a 32bit or 64bit system?

cheers, tim

tim at klingt.org

... to make life worth living ...
  Keith Rowe on making music

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: OpenPGP digital signature
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20090220/93faa9dc/attachment.sig 

More information about the Alsa-devel mailing list