[alsa-devel] Problems recording with HP DV2839TX laptop.

Takashi Iwai tiwai at suse.de
Fri Sep 5 08:28:58 CEST 2008

At Fri, 5 Sep 2008 02:46:50 +1000,
Travis Place wrote:
> Hello everyone,
> Im Travis (wishie) once of the many helpers who man the unofficial #alsa on 
> freenode irc network.. I usually spend my time fixing other peoples sound 
> issues, but now i have my own.
> I have a HP DV2839TX laptop, and i get ALOT of static when recording via the 
> inbuilt mic. Also, the mic controls are very strange.. I have (in the Capture 
> section of alsamixer).. Digital, Docking Mic, External Mic, Internal Mic.. 
> only the "Digital" control seems to effect my recording volume at all. 

The "Digital Capture Volume" is alsa-lib softvol plugin element, and
works globally.  In the case of a digital mic (i.e. usually without a
volume control), sometimes this is the only effective control.

> Strangely, though, the '* Mic' controls in the PLAYBACK section of alsamixer 
> do change the recording properties somewhat (volume being the main factor). 

If you mean about "Mic Boost" or such, then it's a known
(long-standing) bug in ALSA mixer interface.  This appears twice, for
playback and capture, but only the playback one works.

> In any event, i get a rather large amount of static, no matter what mixer 
> settings i try. This isnt a problem in the 'other' OS.
> My alsa-info.sh output for alsa-driver 1.0.16 is at : 
> http://www.alsa-project.org/db/?f=0d1df6446ff1c71ad305e7b7b367f0a6b22b80c8
> My alsa-info.sh output for alsa-driver 1.0.18rc1 is at : 
> http://www.alsa-project.org/db/?f=9e5cd99f4822e0d671866fa630698bd1b0cd954b

It did work on 1.0.16 or not?


More information about the Alsa-devel mailing list