[alsa-devel] Notebook Toshiba satellite x200-21g with realtek snd-hda-intel audio device still not supported (codec ALC268)

Takashi Iwai tiwai at suse.de
Tue Feb 19 17:15:56 CET 2008

At Tue, 19 Feb 2008 16:55:02 +0100,
Daniele (Mastro) wrote:
> Takashi Iwai ha scritto:
> > The mixer setting?  You should set "Digital Capture Volume" 50%,
> > corresponding to 0dB.  The capture volume doesn't have to be too
> > high, too.
> oh..
> i had to play a bit with alsamixer but finally i got a good result...
> my setting:
> - front mic boost = 50 (option: 0, 50, 100)
> - Capture enabled = 65
> - Capture 1 disabled (see below)
> - Digital = 68

Keep this 50%.  It's a digital attenuation/gain control and changing
this makes no sense unless you have a digital mic without the hardware
volume control.

> - Input Source = Front mic
> - Input Source 1 = Front mic (playback - see below)

Is "Front mic" the external mic jack?  And the internal mic works as

> i've discovered some oddity:
> - i have 2 capture device.... (capture and capure 1)
> - the first one is *really* a capture device and work only if i select 
> "front mic", not "mic"
> - the second one is the mic playback device... and again it work only if 
> i use "front mic"
> should it work this way?

The second capture could work independently, assigned to PCM#2.

> > The vref level could be a different one depending on the mic device
> > you are using.  But VREF80 is OK in most cases.
> i don't know what "VREF80" but now capturing with mic work...
> now remaining problems:
> - midi hardware (my card should have it): i've loaded snd-seq-midi 
> module and i've an alsa hardware device but i can't play midi files 
> (they play but i hear nothing...). i've created another alsa-info log 
> taken with the snd-seq-midi loaded http://pastebin.ca/909849

No, you are fooled by marketing people.  It has no MIDI hardware.
It's a pure software thingy.

> - no "mux","mix", or "aux" record source to directly record from desktop

The codec has no function to record from the mixer amp (some other
Realtek codecs have, though).  It's again a software issue.

> - surround still doesn't work
> i should have surround

No, you don't.  aplay just shows the available "configuration" but it
the device doesn't support surrounds.


More information about the Alsa-devel mailing list