[alsa-devel] Notebook Toshiba satellite x200-21g with realtek snd-hda-intel audio device still not supported (codec ALC268)

Daniele (Mastro) daniele.bilug at gmail.com
Tue Feb 19 16:55:02 CET 2008

Takashi Iwai ha scritto:
> The mixer setting?  You should set "Digital Capture Volume" 50%,
> corresponding to 0dB.  The capture volume doesn't have to be too
> high, too.

i had to play a bit with alsamixer but finally i got a good result...

my setting:
- front mic boost = 50 (option: 0, 50, 100)
- Capture enabled = 65
- Capture 1 disabled (see below)
- Digital = 68
- Input Source = Front mic
- Input Source 1 = Front mic (playback - see below)

i've discovered some oddity:

- i have 2 capture device.... (capture and capure 1)
- the first one is *really* a capture device and work only if i select 
"front mic", not "mic"
- the second one is the mic playback device... and again it work only if 
i use "front mic"

should it work this way?

> The vref level could be a different one depending on the mic device
> you are using.  But VREF80 is OK in most cases.

i don't know what "VREF80" but now capturing with mic work...

now remaining problems:
- midi hardware (my card should have it): i've loaded snd-seq-midi 
module and i've an alsa hardware device but i can't play midi files 
(they play but i hear nothing...). i've created another alsa-info log 
taken with the snd-seq-midi loaded http://pastebin.ca/909849
- no "mux","mix", or "aux" record source to directly record from desktop
- surround still doesn't work
i should have surround
$ aplay -L
     HDA Intel, ALC268 Analog
     Default Audio Device
     HDA Intel, ALC268 Analog
     Front speakers
     HDA Intel, ALC268 Analog
     4.0 Surround output to Front and Rear speakers
     HDA Intel, ALC268 Analog
     4.1 Surround output to Front, Rear and Subwoofer speakers
     HDA Intel, ALC268 Analog
     5.0 Surround output to Front, Center and Rear speakers
     HDA Intel, ALC268 Analog
     5.1 Surround output to Front, Center, Rear and Subwoofer speakers
     HDA Intel, ALC268 Analog
     7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
     Discard all samples (playback) or generate zero samples (capture)

but trying
speaker-test -c5 -Dplug:surround41

or any of that other devices produce this error:
Playback device is plug:surround41
Stream parameters are 48000Hz, S16_LE, 5 channels
Using 16 octaves of pink noise
Playback open error: -16,Device or resource busy

the last error repeat itself until i stop it (CTRL+C)
and i hear nothing

are some of this fixable? and can i help in some way fixing them?
thanks again... A LOT!


More information about the Alsa-devel mailing list