[alsa-devel] Notebook Toshiba satellite x200-21g with realtek snd-hda-intel audio device still not supported (codec ALC268)

Takashi Iwai tiwai at suse.de
Tue Feb 19 16:10:00 CET 2008

At Tue, 19 Feb 2008 16:03:18 +0100,
Daniele (Mastro) wrote:
> Takashi Iwai ha scritto:
> > The fix is basically the widget connection of NID 0x23 (and 0x24).
> > This was uninitialized and thus pointed the wrong widget.
> > Unfortunately, this connection couldn't be changed because you
> > apparently have only one input source.  The patch fixes this issue.
> tried the new patch
> (i've compiled a today snapshot and then manually downloaded the last 
> patch_realtek.c version)
> the "front mic" capture now works..
> i've 2 control: front mic and mic.. only mic works
> but i've a lot of crappy noise...
> http://www.mediafire.com/?c1c1jly9n7e
> download this little .wav file i recorded with:
> arecord -vv -f S16_LE -c1 -r48000 -d 5 test.wav
> NOTE: while recording i see the "bar" always at 99%
> thanks for your support.. do you have any idea on what's the cause of 
> that noise?

The mixer setting?  You should set "Digital Capture Volume" 50%,
corresponding to 0dB.  The capture volume doesn't have to be too
high, too.

The vref level could be a different one depending on the mic device
you are using.  But VREF80 is OK in most cases.


More information about the Alsa-devel mailing list