[alsa-devel] Notebook Toshiba satellite x200-21g with realtek snd-hda-intel audio device still not supported (codec ALC268)

Daniele (Mastro) daniele.bilug at gmail.com
Tue Feb 19 16:03:18 CET 2008

Takashi Iwai ha scritto:
> The fix is basically the widget connection of NID 0x23 (and 0x24).
> This was uninitialized and thus pointed the wrong widget.
> Unfortunately, this connection couldn't be changed because you
> apparently have only one input source.  The patch fixes this issue.

tried the new patch
(i've compiled a today snapshot and then manually downloaded the last 
patch_realtek.c version)

the "front mic" capture now works..
i've 2 control: front mic and mic.. only mic works
but i've a lot of crappy noise...

download this little .wav file i recorded with:

arecord -vv -f S16_LE -c1 -r48000 -d 5 test.wav

NOTE: while recording i see the "bar" always at 99%

thanks for your support.. do you have any idea on what's the cause of 
that noise?


More information about the Alsa-devel mailing list