[alsa-devel] Recent ALSA version needs special configuration for Terratec Phase 26 USB

Clemens Ladisch cladisch at fastmail.net
Wed Oct 17 16:01:41 CEST 2007

Janne Himanka wrote:
> I run Debian unstable on my Athlon XP1800 machine,

32 or 64 bits?

> and updating libasound2 package from version 1.0.13-2 to 1.0.14 (and
> later)

Did you try 1.0.15?

> made my Terratec Phase 26 USB soundcard useless. Whenever I tried to
> play something, the program would crash with a segmentation fault.
> When I downgraded to 1.0.13, everything would work again. 
> It took a lot of head scratching and experimentation to find out that
> adding 
> cards.USB-Audio.pcm.use_dmix."USB2448" no
> to my .asoundrc (it is otherwise empty) is needed for it to
> work.

This looks like a bug in the dmix plugin.
Do you have any other USB audio device that works?

Can you get a stack trace from gdb when playing something with aplay?

> The Phase 26 is adaptive; it doesn't need converting for a specific
> format. Bitrates from 32 KHz to 96 KHz and word lengths from 16 to 32
> bits just work.

32-bit samples are not possible with USB audio devices.  I guess ALSA
automatically converts for you.


More information about the Alsa-devel mailing list