[alsa-devel] Recent ALSA version needs special configuration for Terratec Phase 26 USB

Janne Himanka janne.himanka at iki.fi
Wed Oct 17 08:34:43 CEST 2007


I run Debian unstable on my Athlon XP1800 machine, and updating
libasound2 package from version 1.0.13-2 to 1.0.14 (and later) made my
Terratec Phase 26 USB soundcard useless. Whenever I tried to play
something, the program would crash with a segmentation fault. When I
downgraded to 1.0.13, everything would work again. 

It took a lot of head scratching and experimentation to find out that

cards.USB-Audio.pcm.use_dmix."USB2448" no

to my .asoundrc (it is otherwise empty) is needed for it to
work. After adding that, it seems to work as it did before. The string
in hyphens varies according to the mode one selects from the Terratec
front panel. There are four modes with different word length and
bitrates. The Phase 26 is adaptive; it doesn't need converting for a
specific  format. Bitrates from 32 KHz to 96 KHz and word lengths from
16 to 32 bits just work. 

I'm writing you this because a comment in USB-Audio.conf says:

#  If your device requires such a definition to work correctly, please report it
#  to <alsa-devel at alsa-project.org>.

If you need any additional info, I'll be glad to help.

Janne Himanka

More information about the Alsa-devel mailing list