[alsa-devel] Fwd: No sound with ATI SB450

Ben DiDonc ben.didonc at gmail.com
Sun Apr 22 11:45:05 CEST 2007


>Which snapshot did you download?

I used alsa-driver-hd20070421

> It looks as if the driver isn't detecting your codec at all.  Is it
possible that your audio is disabled in bios?

I agree with you. This laptop has a strange BIOS, you can disable a couple
of things (network card,...) but not the sound card.

> Also, Toshiba's are notorious for their acpi issues.  Try rebooting with
"acpi=off" on the kernel boot parameters list.

No  improvement here, no difference with what I had before... still no sound

To help us debug this further if the above steps don't work, try recompiling
> the drivers with "./configure --with-debug=detect --with-cards=hda-intel".
> Then rebuild and reinstall the drivers, and look at the dmesg log with
> "dmesg | fgrep ALSA".

Ok, I rebuild the drivers with the configure options you gave me, and
reloaded them. I grepped my syslog and got a single line out of it:
Apr 22 19:07:50 tosh-it kernel: [89422.940000] ALSA
codec_mask = 0x9

but still no proper senses shown in alsamixer and no sound. See output of
alsa-info.sh at http://pastebin.ca/452475

Your system "should" show up as a Toshiba with RealTek ALC861 audio codec.
> The alsa-info.sh listing doesn't show that codec, but does list the
> subdevice ID.
> Tobin

I did a bit of research on the devel mailing list and found
I tried applying the patch (to hda_intel.c) and realised most of it already
was in the snapshot EXCEPT line 995, which i replaced with the one from the
patch. It now is
for (c = 0; c < azx_max_codecs[chip->driver_type]; c++) {

 I rebuilt the whole lot, reloaded snd_hda_intel and got these two lines
this time:

Apr 22 19:39:01 tosh-it kernel: [91293.576000] ALSA
codec_mask = 0x9
Apr 22 19:39:01 tosh-it kernel: [91293.916000] ALSA
hda_codec: model 'toshiba' is selected for config 1179:ff10 (Toshiba)

This time the right codec is loaded (or so it seems), alsamixer only shows a
PCM control (for playback), but there is still no sound. alsa-info.sh output
at http://pastebin.ca/452493

I m a bit confused with these results...

On Sat, 2007-04-21 at 20:27 +1000, Ben DiDonc wrote:
> Tobin,I downloaded and installed alsa-driver, alsa-lib and alsa-utils, but stillno sound coming out of those speakers...I ran alsa-info.sh and the results are at http://pastebin.ca/451128I am clueless as to what to do next, but I m ready to try anything. Any help would be greatly appreciated.Ben
> On 4/21/07, Tobin Davis < tdavis at dsl-only.net> wrote:>>  Try downloading a current daily snapshot from ftp://ftp.suse.com/pub/projects/alsa/snapshot/> .>> There was an issue with the ATI HD Audio detection that was fixed after> 14rc3 was released.>> Tobin>> On Sat, 2007-04-21 at 16:00 +1000, Ben DiDonc wrote:>> The output of alsa-info.sh is available at http://pastebin.ca/451007>>>  On 4/21/07, *Tobin Davis* < tdavis at dsl-only.net> wrote:>>  Could you download an run http://bulletproof.servebeer.com/alsa/scripts/alsa-info.sh> , then post the resulting link?  This will help determine what setup you> have.>> Tobin Davis>>>> On Sat, 2007-04-21 at 14:56 +1000, Ben DiDonc wrote:>>   Hi I have a toshiba A100 (see attached file lspci-nnv) with a ATI SB450.> Sound worked fine with kernel 2.6.17 and alsa 1.0.12rc1 (ubuntu edgy). I> just did a fresh install of ubuntu feisty (kernel 2.6.20, alsa 1.0.14rc1)> and the only mixer settings available are those of the modem, named off-hook> and caller-id (see output of amixer, aplay -l , and the rest in attached> file output_feisty) I decided to upgrade alsa-driver and alsa-lib to> 1.0.14rc2. after downloading the package, I unloaded all sound related> modules (everything with "snd_" in it) in the right order and did:> ./configure --with-oss=yes --with-cards=hda-intel;make; sudo make install;> sudo modprobe snd_hda_intel A minor improvement: the mixer now shows> controls for both the modem and the sound card (see> output_after_upgrade_to_rc2), but unfortunately, there is still no sound> coming out of those speakers (even though alsamixer shows control for PCM> and the rest...). Finally, I downloaded alsa-driver-1.0.14rc3 and gave it> a shot. This time again, only modem related settings appeared in alsamixer,> and no sound card stuff (see aplay and amixer in> output_after_upgrade_to_rc3), and no sound either. Does anyone know how to> get some sound out of these speakers (given that it used to work with> alsa1.0.12rc1...) ? Thanks for your help Ben>
> >    _______________________________________________Alsa-devel mailing listAlsa-devel at alsa-project.orghttp://mailman.alsa-project.org/mailman/listinfo/alsa-devel>>    --> Tobin Davis <tdavis at dsl-only.net>>>>   --> Tobin Davis <tdavis at dsl-only.net>>_______________________________________________Alsa-devel mailing listAlsa-devel at alsa-project.orghttp://mailman.alsa-project.org/mailman/listinfo/alsa-devel
>   --
> Tobin Davis <tdavis at dsl-only.net>

More information about the Alsa-devel mailing list