[PATCH v4 02/13] ASoC: Intel: catpt: Define DSP operations
Cezary Rojewski
cezary.rojewski at intel.com
Thu Aug 20 09:30:13 CEST 2020
On 2020-08-17 1:12 PM, Cezary Rojewski wrote:
> On 2020-08-13 8:51 PM, Andy Shevchenko wrote:
>> On Wed, Aug 12, 2020 at 10:57:42PM +0200, Cezary Rojewski wrote:
>>
>>> +#define CATPT_DMA_MAXBURST 0x3
>>
>> We have DMA engine definitions for that, please avoid magic numbers.
>>
>
> As with most of the dma stuff, based on existing:
> /sound/soc/intel/common/sst-firmware.c SST_DSP_DMA_MAX_BURST
>
> Ack.
>
Actually, wasn't able to find anything _MAXBURST related in dmaengine.h.
_BUSWIDTH_ have their constants defined there, true, but I'm already
making use of these and this is dst/src_maxburst we're talking about.
From what I've seen in kernel sources, most usages are direct
assignments: xxx_maxburst = Y;
>>> + /* set D3 */
>>> + catpt_updatel_pci(cdev, PMCS, CATPT_PMCS_PS, CATPT_PMCS_PS_D3HOT);
>>> + udelay(50);
>>
>> Don't we have PCI core function for this?
>>
>> ...
>>
>>> + /* set D0 */
>>> + catpt_updatel_pci(cdev, PMCS, CATPT_PMCS_PS, 0);
>>> + udelay(100);
>>
>> Ditto.
>>
>> ...
>>
>>> + /* set D3 */
>>> + catpt_updatel_pci(cdev, PMCS, CATPT_PMCS_PS, CATPT_PMCS_PS_D3HOT);
>>> + udelay(50);
>>
>> Ditto.
>>
>> ...
>>
>>> + /* set D0 */
>>> + catpt_updatel_pci(cdev, PMCS, CATPT_PMCS_PS, 0);
>>
>> Ditto.
>>
>
> Thanks to you now I know the correct answer: yes.
> Ack for all of these. Good advice Andy, again!
Similar situation occurred here. What we're dealing with is: instance of
'struct platform_device' type, found on bus: acpi with PCI set as a
parent device.
Scope found in DSDT:
\_SB_.PCI0.ADSP
sysfs device path:
/sys/devices/pci0000:00/INT3438:00
Within the latter _no_ standard utility files will be available e.g.:
ability to dump PCI config space, bars and such.
I haven't found any functionality to extract "pci_companion" from a
platform_device. What can be made use of is: PCI_D3hot and PCI_D0 enum
constants, as pci_set_power_state() does not apply - expects struct
pci_dev *.
Perhaps got misled by the function naming? catpt_updatel_xxx helpers:
_xxx denotes specific ADSP device's mmio space. Almost all cases are
covered by _pci and _shim.
More information about the Alsa-devel
mailing list