[PATCH 8/8] ASoC: soc-pcm: tidyup dulicate handing at dpcm_fe_dai_startup()
Pierre-Louis Bossart
pierre-louis.bossart at linux.intel.com
Wed Feb 26 16:22:28 CET 2020
On 2/26/20 12:41 AM, Kuninori Morimoto wrote:
> From: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
>
> error handling at dpcm_fe_dai_startup() has duplicate code.
> This patch tidyup it.
>
> Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
> ---
> sound/soc/soc-pcm.c | 6 ++----
> 1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/sound/soc/soc-pcm.c b/sound/soc/soc-pcm.c
> index 1f7a86c4bc02..2fdd90437a6f 100644
> --- a/sound/soc/soc-pcm.c
> +++ b/sound/soc/soc-pcm.c
> @@ -2165,11 +2165,9 @@ static int dpcm_fe_dai_startup(struct snd_pcm_substream *fe_substream)
> goto unwind;
> }
nit-pick: since the two lines below are removed, the 'goto unwind' above
becomes unnecessary. I don't mind if you leave it for symmetry with the
rest of the error handling flow.
> - dpcm_set_fe_update_state(fe, stream, SND_SOC_DPCM_UPDATE_NO);
> - return 0;
> -
> unwind:
> - dpcm_be_dai_startup_unwind(fe, stream);
> + if (ret < 0)
> + dpcm_be_dai_startup_unwind(fe, stream);
> be_err:
> dpcm_set_fe_update_state(fe, stream, SND_SOC_DPCM_UPDATE_NO);
> return ret;
>
More information about the Alsa-devel
mailing list