[alsa-devel] No sound from Headphone Jack over Lenovo Docking Station with T440p Laptop

Raymond Yau superquad.vortex2 at gmail.com
Sat Feb 22 10:03:02 CET 2014

> To make a 5 hour story short, this is my result:
> Using early patching, everything works to my linking:
> 0x16 0x2121101f # dock headphones
> 0x19 0x21a11030 # dock mic
> Thank you very much for your help!
> I guess that building a patch á la ALC269_FIXUP_LENOVO_DOCK is not a big
> deal, but not my business.
> If wanted, I can do testing, as soon as I learn how to properly compile
> and install a custom kernel.


There is already a model lenovo-dock for alc269  but the pins are different
from your t440p

so you need  ALC292_FIXUP_LENOVO_DOCK for your t440p

> I'll post something on
> https://github.com/leoluk/thinkpad-stuff/wiki/Haswell-ThinkPad-problemsto tell other people how to fix this right away.
> More to my story:
> I found /sys/class/sound/hwC1D0, which is a Realtek ALC292 device.
> The NID (what does it stand for?) of interest for the jack's output is
> indeed 0x16.
> When headphones plugged into docking station jack:
> $ sudo hda-verb /dev/snd/hwC1D0 0x16 GET_PIN_SENSE 0
> nid = 0x16, verb = 0xf09, param = 0x0
> value = 0x80000000
> When not plugged:
> $ sudo hda-verb /dev/snd/hwC1D0 0x16 GET_PIN_SENSE 0
> nid = 0x16, verb = 0xf09, param = 0x0
> value = 0x0
> GET_PIN_SENSE for 0x19 is 0x80000000 when headset with mic is plugged into
> dock.
> Pin sense of 0x19 does not change to 0x80000000 when only plugging 3pole
> speaker cable.
> Therefore, I assumed that 0x19 is the dock mic input (turned out later to
> be true).
> I installed alsa-tools-gui and used hdajackretast to override the pin
> config.
> It took a while to find out that not all changes are immediate (early
> patching and restart required).
> Using the early patching values from above, the sound is being redirected
> from the internal speakers to the dock jack, when headphones are connected.
> [When connecting an additional speaker to the left jack on the notebook,
> the sound is output to both dock and notebook jack.]


multiout.max_channels is changed to 4 but you cannot get 4 channels
playback on headphone and dock headphone

+ if (cfg->line_out_type != AUTO_PIN_HP_OUT)
+ spec->const_channel_count = max(spec->const_channel_count,
+ cfg->hp_outs * 2);
+ spec->multiout.max_channels = max(spec->ext_channel_count,
+ spec->const_channel_count);

> When connecting a mic to dock, the dock mic shows up as input and is used
> as such.
> When only connecting a headset without mic, the internal mic stays
> functional.

> I created the output you requested (Lenovo ThinkPad T440p in UltraDock, no
> sound when docked via dock jack but notebook speakers are also mute).
>> not docked: http://pastebin.com/MFQT3R9S
>> docked, no headphones: http://pastebin.com/8UN1sHSM
>> docked, headphones plugged in dock: http://pastebin.com/7XauZLZz
>> docked, headphones plugged in notebook: http://pastebin.com/xfL5qkge
>> Based on that, can you help us getting sound to work on the dock?

More information about the Alsa-devel mailing list