[alsa-devel] Unsupported Valley View 'LPE' adapter?

Adam Williamson awilliam at redhat.com
Wed Feb 19 05:59:28 CET 2014

On Mon, 2014-02-17 at 16:48 -0800, Adam Williamson wrote:
> On Mon, 2014-02-17 at 16:40 -0800, Adam Williamson wrote:
> > On Mon, 2014-02-17 at 09:54 +0000, bobby wrote:
> > > 
> > > This is a pci device for which the driver is not yet available.
> > > I went through the intel atom processor manual and found that it has 3 I2S 
> > > ports, has its 
> > > own DMA. The Soc is interfaced with LPE audio core via internal PCI bus. 
> > > Did you guys hear anything from intel about the driver support. Any inputs 
> > > would be of great help please
> > 
> > Jan Michael Brummer at Intel pointed this out to me recently:
> > 
> > https://kernel.googlesource.com/pub/scm/linux/kernel/git/lrg/asoc/+/intel/haswell-audio-dsp%5E
> > 
> > looks like it's being worked on.
> Heh, that's actually just a mirror of the git ASoC branch. All those
> patches went through this very list last week. I don't know precisely
> how the upstreaming process goes for this stuff, but I'm guessing it'll
> wind up in 3.14 or 3.15.
> (I may try building the patches into my Fedlet kernel builds and see if
> that gets anywhere...)

FWIW, I tried building a 3.14rc3 kernel with these patches applied and
the drivers enabled as modules. On boot on a Dell Venue 8 Pro, all the
relevant modules are loaded, but there's no ALSA device, and no
obviously useful errors in any logs, or useful output from alsa-info.sh.
Is it expected that the driver doesn't actually work yet? Per the recent
commits, do I need some kind of firmware? Any debugging that would be

Adam Williamson
Fedora QA Community Monkey
IRC: adamw | Twitter: AdamW_Fedora | XMPP: adamw AT happyassassin . net

More information about the Alsa-devel mailing list