[alsa-devel] "https://bugtrack.alsa-project.org/alsa-bug" Tascam US122L

Takashi Iwai tiwai at suse.de
Thu Jun 6 15:33:14 CEST 2013

At Thu, 6 Jun 2013 13:56:32 +0100,
James Miller wrote:
> Hi, I can't visit this bugtracker page (above) and am also wondering if
> there is any progress on the Tascam US122L.  I understand someone from the
> kxaudio team has tried a kernel bisect but that the problem lies in the
> driver with a vm switch.
> http://www.remastersys.com/forums/index.php?topic=3013.0
> somewhere I read that this was an alsa problem but I found this kernel
> patch (referred to) and it has been suggested that it is this that is the
> cause.  I am not a prof. developer but might have a go at recompiling my
> kernel after changing the module so that I can get my soundcard working
> with kernel 3.8.13-rt(patch).  Do you guys know anything about this that
> might help me?
> https://patchwork.kernel.org/patch/1258951/

Which driver are you using?  Is snd-usb-us122l or snd-usb-usx2y?

If the patch above is really the culprit of breakage, the driver must
have been already broken before that and it just had worked with
luck.  Both drivers are pretty hackish, and need real fixes...


More information about the Alsa-devel mailing list