[alsa-devel] Thinkpad T400 - internal mic doesn't work, can't set CAPTURE - schematics included

David Henningsson david.henningsson at canonical.com
Thu Feb 28 20:25:56 CET 2013

On 02/28/2013 06:23 PM, Arkadiusz Miśkiewicz wrote:
> On Thursday 28 of February 2013, David Henningsson wrote:
>> On 02/27/2013 06:58 PM, Arkadiusz Miśkiewicz wrote:
>>> Hi,
>>> My Thinkpad T400 (2764CTO model) doesn't have ability to set CAPTURE on
>>> microphone inputs with alsa. Most likely some quirk is missing.
>>> The laptop has internal microphone, microphone in input, headphones out
>>> output and 2 internal speakers. That's all.
>>> Is uses Conexant CX20561_15Z internally and there is detailed T400
>>> schematic available:
>>> http://kythuatphancung.com/download/lenovo-thinkpad-t400-schematic-
>>> diagram.html?dl
>>> (for audio look around page 43).
>>> Kernels 3.7.x, fresh 3.8 - no luck. Tried even linux-next from today but
>>> it dies early on alsa unrelated issues.
>>> I've tried model options laptop, hp, hp-dv6736, hp-700, toshiba, ideapad,
>>> auto. None of these work fine. With model=hp-700 I can set CAPTURE but it
>>> doesn't work (silent audio is captured using arecord or in google
>>> hangout). External mic connected also doesn't work with these setups.
>>> http://www.alsa-project.org/db/?f=394ff4cdca33e75c8a47203d42b89d8de36deca
>>> 7 [3.8 kernel]
>>> http://www.alsa-project.org/db/?f=302877e50f99835075d038207f6db0dfd89873b
>>> 0 [3.7 kernel]
>>> Thinkpad is 2764CTO model exactly.
>>> I can test various hacks, patches etc easily. Could someone look at
>>> schematic and provide quirks to test?
>> Hi,
>> What do you mean with "doesn't have ability to set CAPTURE"?
> On some other notebook I had mic input that I could set to CAPTURE mode using
> space in alsamixer F4: Capture menu. Here I can't set capture on any of inputs
> (pressing space causes no change).

We're increasingly moving away from manual input selection to automatic 
based on what is plugged in.

>> What input
>> is used is automatically selected depending on what you have plugged in,
>> and its level is set using mixer controls (which in your alsa-info is
>> set to minimum levels).
> There are two jack sockets in this laptop, one with headphones icon and other
> with mic icon (on the laptop case itself) as on this photo:
> http://www.notebookreview.com/shared/picture.asp?f=42200
> Ok... maxing all mixer controls and connecting external microphone I get
> external mic being recorded. The mixer controls that seem to be working in
> such mode are: "Mic", "Mic boost" and "Digital". What's weird is that when
> "Digitial" is set to 0 then no sound from microphone is being recorded
> (testing with arecord -f cd | aplay). The "Mic" and "Mic boost" seems to work
> as expectedf. Question: why "Digital" has any influence here?
> Unfortunately I'm unable to get internal microphone working at all. Even with
> all outputs set to maximum like this:
> http://www.alsa-project.org/db/?f=9a7e1ca68b2f2fa2f77dce6ead2b5fb158b74652
> Internal mic is my primary problem.

 From a quick look at the alsa-info things look fine, so I don't know 
what has happened here. Is it a regression from an older kernel, or did 
it never work?

David Henningsson, Canonical Ltd.

More information about the Alsa-devel mailing list