[alsa-devel] Thinkpad T400 - internal mic doesn't work, can't set CAPTURE - schematics included

Arkadiusz Miśkiewicz arekm at maven.pl
Thu Feb 28 18:23:04 CET 2013

On Thursday 28 of February 2013, David Henningsson wrote:
> On 02/27/2013 06:58 PM, Arkadiusz Miśkiewicz wrote:
> > Hi,
> > 
> > My Thinkpad T400 (2764CTO model) doesn't have ability to set CAPTURE on
> > microphone inputs with alsa. Most likely some quirk is missing.
> > 
> > The laptop has internal microphone, microphone in input, headphones out
> > output and 2 internal speakers. That's all.
> > 
> > Is uses Conexant CX20561_15Z internally and there is detailed T400
> > schematic available:
> > http://kythuatphancung.com/download/lenovo-thinkpad-t400-schematic-
> > diagram.html?dl
> > (for audio look around page 43).
> > 
> > Kernels 3.7.x, fresh 3.8 - no luck. Tried even linux-next from today but
> > it dies early on alsa unrelated issues.
> > 
> > I've tried model options laptop, hp, hp-dv6736, hp-700, toshiba, ideapad,
> > auto. None of these work fine. With model=hp-700 I can set CAPTURE but it
> > doesn't work (silent audio is captured using arecord or in google
> > hangout). External mic connected also doesn't work with these setups.
> > 
> > http://www.alsa-project.org/db/?f=394ff4cdca33e75c8a47203d42b89d8de36deca
> > 7 [3.8 kernel]
> > 
> > http://www.alsa-project.org/db/?f=302877e50f99835075d038207f6db0dfd89873b
> > 0 [3.7 kernel]
> > 
> > Thinkpad is 2764CTO model exactly.
> > 
> > I can test various hacks, patches etc easily. Could someone look at
> > schematic and provide quirks to test?
> Hi,
> What do you mean with "doesn't have ability to set CAPTURE"? 

On some other notebook I had mic input that I could set to CAPTURE mode using 
space in alsamixer F4: Capture menu. Here I can't set capture on any of inputs 
(pressing space causes no change). 

> What input
> is used is automatically selected depending on what you have plugged in,
> and its level is set using mixer controls (which in your alsa-info is
> set to minimum levels).

There are two jack sockets in this laptop, one with headphones icon and other 
with mic icon (on the laptop case itself) as on this photo:

Ok... maxing all mixer controls and connecting external microphone I get 
external mic being recorded. The mixer controls that seem to be working in 
such mode are: "Mic", "Mic boost" and "Digital". What's weird is that when 
"Digitial" is set to 0 then no sound from microphone is being recorded 
(testing with arecord -f cd | aplay). The "Mic" and "Mic boost" seems to work 
as expectedf. Question: why "Digital" has any influence here?

Unfortunately I'm unable to get internal microphone working at all. Even with 
all outputs set to maximum like this:


Internal mic is my primary problem.

Arkadiusz Miśkiewicz, arekm / maven.pl

More information about the Alsa-devel mailing list