[alsa-devel] No sound from internal speaker on 2013 Macbook Air 6, 1

Ian Munsie darkstarsword at gmail.com
Sat Aug 24 15:25:34 CEST 2013

Hey all,

I'm trying to get sound working on my new mid 2013 Macbook Air 6,1.
Sound works via the headphone jack, but I haven't managed to get the
internal speaker to work.

I've checked all the controls in the mixer, tried a few different mac
related model= options to snd-hda-intel and even tried tweaking things
with hda_analyzer to no avail. I've uninstalled pulseaudio (for now)
to get rid of it's ALSA hook, but had the same result both with and
without it.

I'm running on a 3.11-rc6+ built today (had a few other fixes to make
for this machine) - I didn't bother including the hda i915 driver as I
don't need sound via the display port, but the hda driver does print a
warning about that missing module. The speaker wasn't working on the
3.10 kernel from Debian either which included that module.

Any help would be appreciated - I've attached my alsa-info output
taken after a reboot.


Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html
-------------- next part --------------
A non-text attachment was scrubbed...
Name: alsa-info.txt.MTy10O6HhS
Type: application/octet-stream
Size: 27954 bytes
Desc: not available
URL: <http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20130824/fe85cfd4/attachment-0001.obj>

More information about the Alsa-devel mailing list