[alsa-devel] M-Audio Delta 1010LT: S/PDIF clock source not working

Jonas Petersen jnsptrsn1 at gmail.com
Tue Apr 9 00:56:23 CEST 2013

Am 07.04.2013 22:35, schrieb Alan Horstmann:
> On Sunday 07 April 2013 18:03, Gabriel M. Beddingfield wrote:
>> On 04/06/2013 05:52 PM, Jonas Petersen wrote:
>>> It seems it's related to the ICE1712... I now tried the Audiophile 2496.
>>> Same behaviour! There is no way to clock from external (S/PDIF). The
>>> 'Multi Track Internal Clock Default' setting will always override the
>>> external clock rate and mess up the capturing.
>> Well, it /should/ work -- according to the 1010's manual.  I'll bet it's
>> some register setting that's missing on the ice1712 -- but I have no
>> access to the specs/datasheets/schematics on these things.
>> I wonder -- did this ever work on Linux?

Yes! I while ago I was doing stuff with the Delta 66 and things were 
fine. That was back with Ubuntu 10.04 and Alsa 1.0.22 and also 1.0.23.
I just grabbed an old Ubuntu 10.04 ISO which contains Alsa 1.0.22 and 
live booted it on my machine. Tests show that it's working as expected 
with the 1010LT: It's properly externally clocked.

> However I do seem to remember some relatively recent changes related 
> to external wordclock on the 1010; maybe it has been broken?

I found commit b8b1a4cb6842fb33769be1ad636f062d31d588c3 from Jan 17 
23:20:03 2011. It's a patch on delta.c and it's regarding a clock issue 
(though not exactly wordclock). I reverted that patch and recompiled but 
no success.

I'm going to continue later on that topic. At least there must have been 
some change that broke it since 1.0.23.

> @Jonas - are you using 'envy24control' to toggle the settings?

I suppose this shouldn't make any difference. I'm using alsamixer, 
amixer and API calls most of the time. Sometimes envy24control, mostly 
for (visual) input feedback. Tried only using envy24control, but didn't 
make any difference.

- Jonas

More information about the Alsa-devel mailing list