[alsa-devel] Fwd: Support for Roland VG-99 (working code, but could use help)

Daniel Mack zonque at gmail.com
Fri Oct 19 19:46:07 CEST 2012

On 19.10.2012 19:02, Pete Leigh wrote:
> On 19 October 2012 09:49, Pete Leigh <pete.leigh at gmail.com> wrote:
>> On 19 October 2012 09:24, Daniel Mack <zonque at gmail.com> wrote:
>>> You should extract the config of the old kernel (/proc/config.gz)
>>> and use this as start for building the upstream.
>  > I'll try re-doing the kernel based off config.gz from the distro
>> kernel, as you suggest,
> [...]
>> If this problem is confined to the usb subsystem, it seems unlikely I
>> broke anything with my config operations, but I'm no expert certainly.
> Perhaps predictably after saying this, I find that using
> /boot/config-3.5.4-1.fc17.x86_64 as .config, then make localmodconfig
> and make menuconfig to turn off loads of network device drivers and
> such that would take hours to compile, usb audio is working on the
> sound.git kernel :-/

Ok, great.

> I quickly tested the VG-99 quirk (modified as per Clemens' suggestion)
> and that works too, so I'll work on generating a patch as per the
> instructions on alsa-project.org.
> If it's any use regarding the urb 0 -ENOSPACE error I was having,  I
> can try and track down the config item difference that makes it work,
> or provide the config files for you to look at.. Please let me know if
> this would be useful.

Absolutely, that would be great. We keep getting reports from users that
see this since the driver was reworked, and I still haven't got my head
around what really causes it. And none of my machines show the error
yet, so it's really hard to track. If you would point me to any specific
config option that reproducibly changes the behaviour, that would be of
great help.

> Should there be some dependency in the configs so that whatever item
> is making the difference is enabled by selecting SND_USB_AUDIO ?

No, it's really just a bug that must be fixed.


More information about the Alsa-devel mailing list