[alsa-devel] [FT C400, PATCH RFC, v4 00/10] M-Audio Fast Track C400

Eldad Zack eldad at fogrefinery.com
Fri Nov 30 15:06:00 CET 2012

Hi Takashi,

On Thu, 29 Nov 2012, Takashi Iwai wrote:
> At Wed, 28 Nov 2012 23:55:31 +0100,
> Eldad Zack wrote:
> > 
> > * Incoroprated the feedback from Clemens Ladisch <clemens at ladisch.de>: 
> > Moved the quirks structure to the right place (also in other places, though
> > not strictly required) and removed the "set quirks" log messages.
> > Thanks, Clemens!
> > 
> > * Added a patch to address the regression introduced by commit
> > 947d299686aa9cc8aecf749d54e8475c6e498956 , "ALSA: snd-usb: properly initialize
> > the sync endpoint". I believe there are no other devices that affected by this
> > issue. Opening only the playback stream without first opening the capture
> > stream now works with the C400.
> Thanks.  I applied all patches except for the new one (2/10 usb-audio:
> correct sync ep init).  This patch needs a bit more care, as it
> seems.
> I know it must be fixed for FT C400 but the fix itself is independent
> from others, so I merged others first to the rest work easier.

Thanks! That's great, now I only need to concentrate on this one
issue. I went through your helpful comments and I'll try to work out a
better patch soon and send it for review.
Should I wait with it until the 3.8 merge window closes?

BTW - given that the code is old, isn't it time to slightly change 
these? :)

card.c: *   (Tentative) USB Audio Driver for ALSA
mixer.c: *   (Tentative) USB Audio Driver for ALSA
usbaudio.h: *   (Tentative) USB Audio Driver for ALSA


More information about the Alsa-devel mailing list