[alsa-devel] Issue when upgrading from 1.0.22 to 1.0.25

Nick Harezga nharezga at gmail.com
Fri Nov 2 12:53:11 CET 2012

I initially tried to send this yesterday from my work e-mail, but I think they
may be blocking the list for some reason. Apologies if this question shows
up twice.

I am attempting to upgrade from Ubuntu version 10.04 to version 12.04. Version
10.04 has ALSA version 1.0.22 and version 12.04 has ALSA 1.0.25. I have a
simple test application that captures microphone input and then plays the
audio through the speaker. When run with ALSA 1.0.22 the program works as
expected. When I run the program with ALSA 1.0.25, I get a bad pipe error
indicating buffer underrun when calling writes. Both systems have the same
hardware (Dell Latitude E6400 laptop).

I tried looking through the change logs to determine if there were any obvious
changes that stood out to me, but couldn't find anything. I have attached
my code. Any suggestions?

Program is compiled using "g++ audio_test.cpp -o audio_test -lasound"

Audio sample rate: 8000
Buffer size: 1800
Format: Signed 16bit LE, interleaved
-------------- next part --------------
A non-text attachment was scrubbed...
Name: audio_test.cpp
Type: text/x-c++src
Size: 4764 bytes
Desc: not available
URL: <http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20121102/6b7d336f/attachment.bin>

More information about the Alsa-devel mailing list