[alsa-devel] Request for compilation test - v1.0.25

David Henningsson david.henningsson at canonical.com
Mon Jan 23 17:27:19 CET 2012

On 01/23/2012 12:11 PM, Jaroslav Kysela wrote:
> Hi all,
> 	I would like to ask for a package compilation test in your distribution
> for latest ALSA package snapshots available at:
> http://www.alsa-project.org/snapshot/

I have done a quick test compilation of these in the development version 
of Ubuntu, 12.04. So far, I did not test installing them.

> 	At this time, these snapshots are available:
> alsa-driver

Compiles without problems.

> alsa-lib

Compiles without problems.

> alsa-utils

Fails at configure (probably just requires headers from the alsa-lib 


> alsa-firmware

Compiles without problems.

> alsa-tools

Fails with:

configure.in:20: error: possibly undefined macro: AM_PATH_LD10K1


Also, this package refuses to build in parallel (I'm running "make -j5").

> alsa-oss

Compiles without problems.

> alsa-plugins

Fails with:

make[2]: *** No rule to make target `50-pulseaudio.conf', needed by 
`all-am'.  Stop.


> alsa-python

I'm not familiar with building python packages, but "python setup.py 
build" seems to compile without problems.

> 	Please, report any compilation/installation issues to this list (you
> may add CC to me). I am going to make 1.0.25 release on Wednesday.
> 	The alsa-driver package will not support the kernels bellow 2.6.18
> (released Sep 20 2006), from README:
>   - Vanilla 3.0 to 3.2
>   - Vanilla 2.6.18 to 2.6.39
> 	I kept the 2.4 build code, but it is not maintained and definitely, it
> will be removed in next alsa-driver versions.
> 				Jaroslav

David Henningsson, Canonical Ltd.

More information about the Alsa-devel mailing list