[alsa-devel] [PATCH v2]ASoC:blackfin:add ad73311 card driver name
scott.jiang.linux at gmail.com
Fri Sep 16 05:53:16 CEST 2011
2011/9/15 Mark Brown <broonie at opensource.wolfsonmicro.com>:
> On Wed, Sep 14, 2011 at 11:27:28AM +0800, Scott Jiang wrote:
>> 2011/9/13 Mark Brown <broonie at opensource.wolfsonmicro.com>:
>> > On Tue, Sep 13, 2011 at 02:59:26PM -0400, Scott Jiang wrote:
>> > All my comments about the previous revision of the patch continue to
>> > apply here. The changlog doesn't explain the issue well (the driver
>> > should already end up with a unique name)
>> in alsa lib snd_config_hook_load_for_all_cards(), use
>> sndrv_ctl_card_info->driver to determine card config,
>> not sndrv_ctl_card_info->name, though card name contains enough info.
> So the issue isn't that the driver doesn't have a name, it's that you
> don't like the name it was given.
Do you mean alsa lib needs to modify its way to determine which card
config to load?
I don't think alsa lib guys will agree.
>The changelog needs to explain this,
> and also explain why this is an issue in this one driver.
Not only for this one driver, it's a problem for all drivers under
asoc. Because sndrv_ctl_card_info->driver is an empty string now.
>> > and the name you've picked
>> > is less distinctive than the existing name.
>> I know the name is not good enough, but it is a historical result.
>> Asoc copy codec name to card->driver before, cause all cards config
>> file in alsa lib conf dir have this kind of name.
> This sounds like you should fix userspace. It does go back to the issue
> I regularly raise with the Blackfin code constantly assuming that there
> can be a single driver which covers all combinations of a Blackfin CPU
> with a given CODEC.
As I have said it was caused by ASoC before. It is not a guilt of blackfin.
All drivers under ASoC must name their card config the same as their
codec driver's name because asoc copy codec name to snd_card->driver
and alsa lib get it through sndrv_ctl_card_info->driver. They must
Now ASoC doesn't copy codec name to snd_card->driver so we can rename
it to bfin-ad73311 if you like this kind of name style.
More information about the Alsa-devel