[alsa-devel] Regression post-ALSA 1.0.22 for Lenovo G555 Internal mic

Takashi Iwai tiwai at suse.de
Tue May 24 13:07:21 CEST 2011

At Tue, 24 May 2011 11:57:16 +0100,
Roo - Andrew Baines wrote:
> I tried the patch but for some reason it fails, am i using patch wrong? When
> I try and open it in Kompare it says its not a valid diff file.

Did you save it as a raw file?  Otherwise gmail interface breaks lines
and spaces badly.

> shark alsa-kernel # patch -p2 </home/roo/alsa-patch
> patching file pci/hda/patch_conexant.c
> Hunk #1 FAILED at 3484.
> Hunk #2 FAILED at 3508.
> Hunk #3 FAILED at 3519.
> Hunk #4 FAILED at 3703.
> Hunk #5 FAILED at 3757.
> 5 out of 5 hunks FAILED -- saving rejects to file
> pci/hda/patch_conexant.c.rej
> New alsa-info.sh output is attached also.
> When I ran arecord with pasuspender I got an error 'D is not a valid option'
> so I killed pulse and did arecord.

Then pass like "pasuspender -- arecord ....".  Depending on PA
version, you need "--".

> What I got was a 0.00 second long
> recording even if i specified --duration=10.
> There are no alsa records in /var/log/messages at all when I grep for ALSA,
> alsa, conexant, snd, sound.

You have the following kernel messages:
[ 3798.888009] ALSA hda_intel.c:717: azx_get_response timeout, switching to polling mode: last cmd=0x001f000a
[ 3799.892016] ALSA hda_intel.c:756: hda_intel: azx_get_response timeout, switching to single_cmd mode: last cmd=0x001f000a

This is rather a fatal error, which makes impossible to get
unsolicited events from the codec.

And, judging from alsa-info.sh output, you are still using the old
driver.  With the new driver, you must have "Auto-Mute" enum mixer
element.  That is, the installation from the snapshot tarball failed
somehow.  Double-check what went wrong.  The error above should have
been fixed in the recent version.

BTW, I fixed another issue in auto-mute mode, so try the latest
snapshot tarball again.



More information about the Alsa-devel mailing list