[alsa-devel] compile problems

David Henderson dhenderson at digital-pipe.com
Mon Jun 27 16:59:34 CEST 2011

On 06/27/2011 10:25 AM, Adrian Pardini wrote:
> On 27/06/2011, David Henderson<dhenderson at digital-pipe.com>  wrote:
>> On 06/27/2011 09:35 AM, Adrian Pardini wrote:
> [...]
>>> Hi Dave, try giving --with-alsa-inc-prefix=/opt/staging/alsa to the
>>> configure script.
>> Thanks for the help Adrian.  I tried passing that parameter to the
>> configure script and here's the below output:
>> checking for libasound headers version>= 1.0.16... not present.
>> configure: error: Sufficiently new version of libasound not found.
>> I've double checked that the header files are present:
>> $ ls -1 /opt/staging/alsa/var/share/include/alsa/
> My bad, here it works using ./configure
> --with-alsa-inc-prefix=/usr/include/alsa/ so I think you should use
> ./configure --with-alsa-inc-prefix=/opt/staging/alsa/var/share/include/alsa/.
>   If you are not in a hurry I can try to replicate your directory
> structure when I get back to home. Also you may have to set the
> LDFLAGS environment variable to point to where your libraries are
> being installed under /opt

Thanks for the continued help Adrian.  I tried the adjusted configure 
parameter value, but it's still giving the same error message.  
Currently I'm in no rush, so let me know once you're able to get home.  
Also, if you need my compiled version of the alsa-lib package (or any 
other info), let me know.


More information about the Alsa-devel mailing list