[alsa-devel] MIDI issue with RME HDSPM MADI

Jörn Nettingsmeier nettings at stackingdwarves.net
Tue Jun 7 15:18:19 CEST 2011

On 06/07/2011 03:06 PM, Jörn Nettingsmeier wrote:
> On 06/05/2011 02:34 PM, Jörn Nettingsmeier wrote:
>> On 06/03/2011 06:08 PM, Takashi Iwai wrote:
>>> At Wed, 01 Jun 2011 19:27:32 +0200,
>>> Jörn Nettingsmeier wrote:
>>>> Hi *!
>>>> The HDSPM MADI driver seems to have an issue with its MIDI
>>>> implementation. It is rock-solid for audio under Jack at 64
>>>> frames/period, but as soon as I start using the MIDI over MADI interface
>>>> (to remote-control my Micstasy preamps), I'm getting xruns every ten
>>>> seconds or so.
>>> Maybe we can just replace the midi stuff into workqueue.
>>> Below is a very quick and untested patch.  Does it work?
>> patch applies and works, no crashes here.
>> but no change in xrun behaviour either.
>> for the record, i'm running the kernel with threadirqs.
>> i guess by using a workqueue, we have eliminated the possibility that
>> anything in the midi bottom half of the driver is hogging the hardware
>> resources to cause an xrun, right?
> new datapoint: the xruns are the same when i use the physical midi
> interface of the HDSP MADI instead of the MIDI over MADI one.
> i wonder: can anybody reproduce this issue with another card supported
> by the hsdpm.c driver?

GOTCHA. it looks like it's higher up in the code. i just ran jack with 
my RME DIGI9652 (different driver!), and presto: when i ran faberman's 
rawmiditest or the micstasy remote (on the MADI card, not on the DIGI), 
there's xruns again. slightly less, but very likely caused by midi 
traffic. i'm just cross-checking with a make -j8 kernel build, and there 
are no xruns, only when i have midi traffic.

Jörn Nettingsmeier
Lortzingstr. 11, 45128 Essen, Tel. +49 177 7937487

Meister für Veranstaltungstechnik (Bühne/Studio)
Tonmeister (VDT)


More information about the Alsa-devel mailing list