[alsa-devel] Adding a "capture" device naming scheme

Jaroslav Kysela perex at perex.cz
Wed Jan 12 10:17:22 CET 2011

On Wed, 12 Jan 2011, Colin Guthrie wrote:

> 'Twas brillig, and Takashi Iwai at 12/01/11 06:53 did gyre and gimble:
>> I read Colin meant front:CARD=x is incorrect while hw:CARD is a lowlevel
>> access that one doesn't always want.
> For capture. Yes that's what I was meaning.
>> I'm fine with creating a new name, but wondering which name is best.
>> Basically what you want here is the default use-case but without
>> dsnoop like the current "default".  (If dsnoop were acceptable,
>> "default" should have been used in most places.)
>> "capture" may be also too ambiguous for defining that, I'm afraid.
> Yeah, "default" wont work here due to it being redirected to PulseAudio
> (as opposed to dsnoop) in this use case, so we need to avoid that name :s
> IMO "capture" is quite clear (or at least as clear as "front" is for
> playback!), but here are a few other suggestions:
> "record"
> "input"
> "read"
> Personally, "input" and "capture" are my two favourites.

The question is, if we should identify more the source of the captured 
data. The default device does the basic job.





Jaroslav Kysela <perex at perex.cz>
Linux Kernel Sound Maintainer
ALSA Project, Red Hat, Inc.

More information about the Alsa-devel mailing list