[alsa-devel] Adding a "capture" device naming scheme

Colin Guthrie gmane at colin.guthr.ie
Wed Jan 12 10:10:10 CET 2011

'Twas brillig, and Takashi Iwai at 12/01/11 06:53 did gyre and gimble:
> I read Colin meant front:CARD=x is incorrect while hw:CARD is a lowlevel
> access that one doesn't always want.

For capture. Yes that's what I was meaning.

> I'm fine with creating a new name, but wondering which name is best.
> Basically what you want here is the default use-case but without
> dsnoop like the current "default".  (If dsnoop were acceptable,
> "default" should have been used in most places.)
> "capture" may be also too ambiguous for defining that, I'm afraid.

Yeah, "default" wont work here due to it being redirected to PulseAudio
(as opposed to dsnoop) in this use case, so we need to avoid that name :s

IMO "capture" is quite clear (or at least as clear as "front" is for
playback!), but here are a few other suggestions:


Personally, "input" and "capture" are my two favourites.



Colin Guthrie

Day Job:
  Tribalogic Limited [http://www.tribalogic.net/]
Open Source:
  Mageia Contributor [http://www.mageia.org/]
  PulseAudio Hacker [http://www.pulseaudio.org/]
  Trac Hacker [http://trac.edgewall.org/]

More information about the Alsa-devel mailing list