[alsa-devel] hdspmixer segfault (1.0.24+)

Fernando Lopez-Lezcano nando at ccrma.Stanford.EDU
Sun Feb 27 20:21:44 CET 2011

On 02/27/2011 03:17 AM, Adrian Knoth wrote:
> On Sat, Feb 26, 2011 at 04:55:24PM -0800, Fernando Lopez-Lezcano wrote:
>> Hi, I'm getting a segfault from hdspmixer using the current git
>> alsa-tools (1.0.23 works, 1.0.24+ does not). See below for a backtrace.
>> I'm running 2.6.33.x rt30, could this be the problem? (a dependency on
>> newer kernels?)
> I have fixed this bug a couple of days ago:
>     http://thread.gmane.org/gmane.linux.alsa.devel/82452
> They still need to be applied to the alsa-tools.git, but if you like,
> you can grab the patches and verify they work for you.

They do work in a first (remote) test. Thanks very much!!
-- Fernando

More information about the Alsa-devel mailing list