[alsa-devel] TWL4030 Line In/Out Loopback issue

Péter Ujfalusi peter.ujfalusi at ti.com
Tue Aug 9 08:40:44 CEST 2011

On Monday 08 August 2011 17:01:11 Almohanad Fayez wrote:
>  Péter,
> I can't seem to find a Left/Right Digital Loopback the mention of a loop I
> found is an FM Loop Enable.  The following is the dapm_widget enable output
> from my Gumstix Overo running the 2.6.38 Kernel.  Thanks for your help.

Look for the control:
amixer -c0

Look for the Left/Right Digital Loopback in the list, and check the value

> root at usrp-e1xx:~# cat /sys/devices/platform/soc-audio/TWL4030/dapm_widget
> Headset Mic Bias: Off
> Mic Bias 2: Off
> Mic Bias 1: Off
> micbias2 select: Off
> micbias1 select: Off
> Digimic1 Enable: Off
> Digimic0 Enable: Off
> ADC Physical Right: On
> ADC Physical Left: On
> Analog Right: On
> Analog Left: On
> ADC Virtual Right2: Off
> ADC Virtual Left2: Off
> ADC Virtual Right1: Off
> ADC Virtual Left1: Off
> HandsfreeR PGA: Off
> HandsfreeL PGA: Off
> CarkitR PGA: Off
> CarkitR Mixer: Off
> CarkitL PGA: Off
> CarkitL Mixer: Off
> HeadsetR PGA: On
> HeadsetR Mixer: On
> HeadsetL PGA: On
> HeadsetL Mixer: On
> PredriveR PGA: Off
> PredriveR Mixer: Off
> PredriveL PGA: Off
> PredriveL Mixer: Off
> Earpiece PGA: Off
> Earpiece Mixer: Off
> AIF Enable: On
> APLL Enable: Off
> Analog Voice Playback Mixer: Off
> Analog L2 Playback Mixer: On
> Analog R2 Playback Mixer: On
> Analog L1 Playback Mixer: Off
> Analog R1 Playback Mixer: Off
> Digital Voice Playback Mixer: Off
> Digital L2 Playback Mixer: On
> Digital R2 Playback Mixer: On
> Digital L1 Playback Mixer: Off
> Digital R1 Playback Mixer: Off
> FM Loop Enable: Off
> DAC Voice: Off
> DAC Left2: Off
> DAC Right2: Off
> DAC Left1: Off
> DAC Right1: Off
> PM State: On

It does seams that the digital loopback is enabled from this.
You had only capture running while taken this, right?


More information about the Alsa-devel mailing list