[alsa-devel] No sound with HDA ATI HDMI since kernel 3.0

Yannick Palanque yannick.ml at palanque.name
Mon Aug 8 22:42:52 CEST 2011


First, I'm sorry for my english is awkward and I'm not sure if I'm at
the right place.

I use Linux amd64 and have two sound "cards":

 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe9f8000 irq 47
Graphic card:
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfeaec000 irq 48

(lspci ouput and alsa-info.txt attached)

I have no problem with
With kernel 3.0 and 3.0.1, I have no sound with HDMI output.

VLC 1.1.3 gives me no sound (I don't see any error message).
MPlayer SVN-r31918 (with correct -ao alsa:device=hw=1.3 option, it
works with gives me no sound and I see the audio position in
seconds on status line going approximatively 6 times faster than normal
(in fact, video is 6 times faster, too).

I attached dmesg output for kernels and 3.0.1.

For both kernels, I have the line
	hda-intel: IRQ timing workaround is activated for card #1.
	Suggest a bigger bdl_pos_adj.

I tried modifying parameters bdl_pos_adj and position_fix, because I
read that some people tried this, when I searched for this problem, but
only worked, with default setup (see attached tests.txt file).

I also tried to replace the files in sound/pci/hda/* from (I
read that about Debian bug 635362 in this very list) but it doesn't work

I'm only a modest user and I don't know what to do best, but I would be
delighted if I could help to solve what I believe to be a bug on a
specific hardware.

Yannick Palanque
-------------- next part --------------
A non-text attachment was scrubbed...
Name: alsa-info.txt.bz2
Type: application/x-bzip
Size: 6132 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20110808/a7526050/attachment-0004.bz2 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dmesg_2.6.39.3.bz2
Type: application/x-bzip
Size: 13943 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20110808/a7526050/attachment-0005.bz2 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dmesg_3.0.1.bz2
Type: application/x-bzip
Size: 14006 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20110808/a7526050/attachment-0006.bz2 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: lspci.bz2
Type: application/x-bzip
Size: 2213 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20110808/a7526050/attachment-0007.bz2 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: tests.txt
Url: http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20110808/a7526050/attachment-0001.txt 

More information about the Alsa-devel mailing list