[alsa-devel] No sound with HDA ATI HDMI since kernel 3.0

Takashi Iwai tiwai at suse.de
Tue Aug 9 09:25:09 CEST 2011

At Mon, 8 Aug 2011 22:42:52 +0200,
Yannick Palanque wrote:
> Hello,
> First, I'm sorry for my english is awkward and I'm not sure if I'm at
> the right place.
> I use Linux amd64 and have two sound "cards":
> Motherboard:
>  0 [Intel          ]: HDA-Intel - HDA Intel
>                       HDA Intel at 0xfe9f8000 irq 47
> Graphic card:
>  1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
>                       HDA ATI HDMI at 0xfeaec000 irq 48
> (lspci ouput and alsa-info.txt attached)
> I have no problem with
> With kernel 3.0 and 3.0.1, I have no sound with HDMI output.
> VLC 1.1.3 gives me no sound (I don't see any error message).
> MPlayer SVN-r31918 (with correct -ao alsa:device=hw=1.3 option, it
> works with gives me no sound and I see the audio position in
> seconds on status line going approximatively 6 times faster than normal
> (in fact, video is 6 times faster, too).
> I attached dmesg output for kernels and 3.0.1.
> For both kernels, I have the line
> 	hda-intel: IRQ timing workaround is activated for card #1.
> 	Suggest a bigger bdl_pos_adj.

This message is irrelevant from your problem.

> I tried modifying parameters bdl_pos_adj and position_fix, because I
> read that some people tried this, when I searched for this problem, but
> only worked, with default setup (see attached tests.txt file).
> I also tried to replace the files in sound/pci/hda/* from (I
> read that about Debian bug 635362 in this very list) but it doesn't work
> better.

If replacing the sound driver code doesn't fix, it means the problem
is rather in the video-driver side.  Better to ask video guys.


More information about the Alsa-devel mailing list