[alsa-devel] Conexant CX20585 recording does not work

David Henningsson david.henningsson at canonical.com
Thu Apr 7 14:42:13 CEST 2011

On 2011-04-07 14:34, Gabriel Schulhof wrote:
> Hi!
> My mom has a laptop with the following sound card:
> lspci: 00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
> (rev 40)
> driver: snd_hda_intel
> alsamixer:
> Card: HDA ATI SB
> Chip: Conexant CX20585
> I can't record from this card no matter what I try. It seems that
> alsamixer has a lot of options:
> Mic B<Capture switch>
> Mic C<Capture switch>
> Mic E<Capture switch>
> Mic F<Capture switch>
> Capture<0% -- 100% slider>
> Analog Mic Boost<0 db -- 40 db slider with 10 db increment>
> I have tried to record from each mic in turn, I have tried the different
> boost levels (0 db - 40 db), but I have had no luck picking up anything. I
> have attached an external mic to the line-in, but no difference.
> When I say "I have tried to record" I mean that I logged into her
> computer, chose one of the mics from the above list, and then I told my
> mom to say something while looking at the input sound level indicator in
> the GNOME sound settings panel. On other computers, I have found this a
> sufficient indication of whether the mic works.
> Is this inability to record a known limitation of this sound card? If not,
> is there some special setting I have to modify to make it work?
> Please find attached the output from alsa-info.
> TIA for your help,

Please try the model quirk "hp-laptop". In Ubuntu that would be adding 
the line:

options snd-hda-intel model=hp-laptop

to the file /etc/modprobe.d/alsa-base.conf

I guess it's the same in Fedora. If it works, we'll create a quirk.

(Memo to self: You should really help out with that cxt5066 autoparser 

David Henningsson, Canonical Ltd.

More information about the Alsa-devel mailing list