[alsa-devel] Conexant CX20585 recording does not work

Gabriel Schulhof nix at go-nix.ca
Thu Apr 7 14:34:59 CEST 2011


My mom has a laptop with the following sound card:

lspci: 00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
(rev 40)

driver: snd_hda_intel

Chip: Conexant CX20585

I can't record from this card no matter what I try. It seems that
alsamixer has a lot of options:

Mic B            <Capture switch>
Mic C            <Capture switch>
Mic E            <Capture switch>
Mic F            <Capture switch>
Capture          <0% -- 100% slider>
Analog Mic Boost <0 db -- 40 db slider with 10 db increment>

I have tried to record from each mic in turn, I have tried the different
boost levels (0 db - 40 db), but I have had no luck picking up anything. I
have attached an external mic to the line-in, but no difference.

When I say "I have tried to record" I mean that I logged into her
computer, chose one of the mics from the above list, and then I told my
mom to say something while looking at the input sound level indicator in
the GNOME sound settings panel. On other computers, I have found this a
sufficient indication of whether the mic works.

Is this inability to record a known limitation of this sound card? If not,
is there some special setting I have to modify to make it work?

Please find attached the output from alsa-info.

TIA for your help,

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: alsa-info.txt
Url: http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20110407/60a3771b/attachment-0001.txt 

More information about the Alsa-devel mailing list