[alsa-devel] how to mandate the use of PCM plugin?

David Henningsson david.henningsson at canonical.com
Wed Sep 29 11:28:43 CEST 2010

On 2010-09-28 06:07, Raymond Yau wrote:
> 2010/9/28 Colin Guthrie<gmane at colin.guthr.ie>
>> And today, one of the Canonical guys published his version of a tool to
>> help here:
>> http://thread.gmane.org/gmane.comp.audio.pulseaudio.general/7542
>> Hope this helps.
>> Col
> why did runtest.sh use a format  FLOAT64_LE which was not supported by PA ?

runtest.sh isn't meant to be used directly in that way, you're supposed 
to run "alsamixertest". Try "alsamixertest -r" and "alsamixertest -h" to 
get started. (Perhaps I should rename the .sh file to something else.)

That said, if you find a good use case where you want to use it directly 
and need a different sample format - patches welcome (as long as they 
don't break something else).

David Henningsson, Canonical Ltd.

More information about the Alsa-devel mailing list