[alsa-devel] Since kernel-2.6.32 alsactl thinks my sound card is "Unknown"

Takashi Iwai tiwai at suse.de
Thu Sep 2 10:29:51 CEST 2010

At Wed, 01 Sep 2010 18:15:23 +0200,
Pacho Ramos wrote:
> This is an old problem I am suffering since kernel-2.6.32 and that is
> still unresolved even with 2.6.35 and alsa-utils-1.0.23:
> http://www.spinics.net/lists/alsa-devel/msg31422.html
> If you follow the thread, it got stalled in:
> http://www.spinics.net/lists/alsa-devel/msg31433.html
> In summary, I get the following:
> # alsactl -f /etc/asound.state restore /dev/snd/controlC0 
> Unknown hardware: "VIA8237" "Realtek ALC658D" "AC97a:414c4781" "0x147b"
> "0x1415"
> Hardware is initialized using a guess method
> # echo $?
> 99

This is no error.  It means that alsactl has no special workaround
for your hardware.  The return code of alsactl looks strange.
I thought Jaroslav has already fixed it, though...


> As you can see, the exit code was solved, but I don't know why my
> hardware is still shown as "Unknown" even if 
> via82xx.c clearly has some lines for my device:
>         SND_PCI_QUIRK(0x147b, 0x1415, "ABIT AV8", VIA_DXS_NO_VRA),
> Thanks a lot for your help
> [1.2 This is a digitally signed message part <application/pgp-signature (7bit)>]
> [2  <text/plain; us-ascii (7bit)>]
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at alsa-project.org
> http://mailman.alsa-project.org/mailman/listinfo/alsa-devel

More information about the Alsa-devel mailing list