[alsa-devel] poor sound from ALC 850/880 in alsa 1.0.21 and 1.0.23

Colin Kincaid Williams discord at uw.edu
Sat Nov 27 05:19:49 CET 2010


 I'm experiencing crap sound preformance from my ALC 850/880 chipset.
 I'm first wondering if their is a way to set the model other than the
 /etc/modprobe.d/alsa-base.conf file? Can I try different models
 without rebooting? So far I've tried the model 6stack, since that
 sounds like what I have on my motherboard. Furthermore, does anybody
 have any ideas on what else I can do so that my computer can sound at
 least as good as my $20 coby mp3 player?

I've tried both driver version 1.0.21 and more recently 1.0.23, with
no improvment in sound.

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.23.
Compiled on Nov 26 2010 for kernel 2.6.32-5-amd64 (SMP).

 cat /proc/asound/version
 Advanced Linux Sound Architecture Driver Version 1.0.21.

 The output from lspci :

 00:10.1 Audio device [0403]: nVidia Corporation MCP51 High Definition
 Audio [10de:026c] (rev a2)
 =A0 =A0 =A0 =A0Subsystem: Giga-byte Technology Device [1458:a102]
 =A0 =A0 =A0 =A0Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop=
- ParErr-
 Stepping- SERR- FastB2B- DisINTx-
 =A0 =A0 =A0 =A0Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=3Dfast >T=
 <TAbort- <MAbort- >SERR- <PERR- INTx-
 =A0 =A0 =A0 =A0Latency: 0 (500ns min, 1250ns max)
 =A0 =A0 =A0 =A0Interrupt: pin B routed to IRQ 22
 =A0 =A0 =A0 =A0Region 0: Memory at f5100000 (32-bit, non-prefetchable) [s=
 =A0 =A0 =A0 =A0Capabilities: [44] Power Management version 2
 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0Flags: PMEClk- DSI- D1- D2- AuxCurrent=3D0=
mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0Status: D0 NoSoftRst- PME-Enable- DSel=3D0=
 DScale=3D0 PME-
 =A0 =A0 =A0 =A0Capabilities: [50] MSI: Enable- Count=3D1/1 Maskable+ 64bi=
 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0Address: 0000000000000000 =A0Data: 0000
 =A0 =A0 =A0 =A0 =A0 =A0 =A0 =A0Masking: 00000000 =A0Pending: 00000000
 =A0 =A0 =A0 =A0Capabilities: [6c] HyperTransport: MSI Mapping Enable+ Fix=
 =A0 =A0 =A0 =A0Kernel driver in use: HDA Intel

More information about the Alsa-devel mailing list