[alsa-devel] SPDIF out with HDA/Conexant 20561?

pl bossart bossart.nospam at gmail.com
Thu May 6 21:02:17 CEST 2010

I managed to have playback working for both PCM and AC3 in passthrough
mode, found out there is a configuration issue in the HDAudio codec.
By default the SPDIF pin isn't enabled, configuring it as PIN_OUT is
required. Also for some reason there's a switch that selects a quirk
for no good reason. I need to look into this, but here's the fix for
The question is if SPDIF pin is never configured as out, did it ever
work for anyone using Conexant codecs?

On Wed, May 5, 2010 at 10:59 AM, Jerone Young
<jerone.young at canonical.com> wrote:
> On Wed, 2010-05-05 at 07:29 -0500, pl bossart wrote:
>> > Are you using the Thinkpad Docking station with the S/PDIF on the side?
>> > The headphone jack on those doesn't have S/PDIF.
>> Yes I am using the side coax connector on the docking station.
> I know the T61 is properly wired for it. Had a chance to try it in
> person. It also had a AD codec as opposed to conexant.
>> > I have not been able to verify this so glad your email came.. but it
>> > seems like the T400, T500, & W500 do not actually work with it.
>> >
>> > Did you try under Windows & if so did it work?
> This has been the main issue. Can't get a total confirmation that it
> even works to begin with for these machines. Also Lenovo has removed the
> port from the recent line of docking stations.
> If I can find anything useful .. I'll reply back soon.
> I really wanted to remove the SPDIF port being exposed as it shows up on
> my X301 .. and X200 (They all have the same codec), but don't use that
> docking station. But the use case your trying to do is the only way to
> do it and it would only be with the T400/T500 & W500 .. though no where
> can I find someone clearly saying they got it to work (even with
> Windows).
>> No I don't have Windows on this thing. For now I have no real way to
>> tell if the output is properly configured, if the connector works, if
>> the cable's bad...
>> Cheers
>> - Pierre
>                        Thanks,
>                                Jerone
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cxt5051.patch
Type: application/octet-stream
Size: 1042 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20100506/870385fd/attachment.dll 

More information about the Alsa-devel mailing list