[alsa-devel] no audio output with TYAN S7025 motherboard and Realtek ALC262

Bryan Green bryan.d.green at nasa.gov
Wed Mar 10 20:37:56 CET 2010

Hi Paul,

Paul Menzel <paulepanter <at> users.sourceforge.net> writes:
> Dear Bryan,
> Am Mittwoch, den 03.03.2010, 10:54 -0800 schrieb Bryan Green:
> > I have several systems with a TYAN S7025 motherboard and Realtek ALC262 
> > chipset.
> > I have not been able to produce any audio output.  Well, that is except
> > for
> > one of the systems: after a variety of tweeks and tests, I got sound
> > working
> > on one system, but I do not know what change enabled sound to start
> > working,
> > and I have not been able to reproduce the effect on the other systems.
> Can you give list of what tweeks you did (even incomplete).

I tried changing the 'model' setting several times, before reverting back
to the default.  I reran 'alsaconf' several times in the process, and
occasionally noticed changes to the set of mixer elements listed by
alsamixer.  Sometimes a "PCM" element would be present, other times not.  I
also upgraded t the kernel from 2.6.31 to 2.6.32.  While in 2.6.32, with
the default 'model' setting (i.e.  auto), I was in the alsamixer and
unmuted one of the elements - I think it was the "Front Mic" element.
Suddenly, audio started working.  I then muted all the mixer elements
except master and maybe PCM (if PCM was present at the time).  Audio
remained working.  I booted back into 2.6.31.  Audio still worked.  I
couldn't get it to stop working at that point, in order to try to reproduce
the original problem.  I also was not able to reproduce success on the
other systems with the same hardware.

> Have you tried different values for the model parameter [1]? If I am not
> mistaken you can use HDA-Analyzer [2] to change such values. But I never
> used it myself.

I tried a few values for 'model'.  I have not tried HDA-Analyzer.  I had
hoped to avoid going in that deep.



More information about the Alsa-devel mailing list