[alsa-devel] [RFC 2/2] ASoC: tlv320dac33: Request for reordered update power sequence
peter.ujfalusi at nokia.com
Fri Dec 3 10:36:27 CET 2010
On Thursday 02 December 2010 15:15:06 ext Mark Brown wrote:
> On Thu, Dec 02, 2010 at 02:52:04PM +0200, Peter Ujfalusi wrote:
> > Back to the naming.. What about reorder_dapm_update_power, and move the
> > flag to the snd_soc_dapm_widget struct?
> If we're going down this route I'd rather have a name that reflected the
> new ordering rather than the fact that there's an ordering change. Not
> that any ideas occur to me right now.
A bit long, but this describes well the meaning.
I think it is kind of silly to have a function, which just sets this flag, and I
think having yet another DAPM widgets for this type is again a bad idea.
Do we have helper function, which can find a widget by name, and return the
pointer to the snd_soc_dapm_widget?
I think if we have that, drivers can use that to get the widget they want to
change the power up order, and set this flag.
If we ever need other new flags for widgets, this can be used for that purpose.
We could have an inline function, which uses the dapm_find_widget(), and sets
the flag, to minimize duplicated code all over the place.
So I can move the flag per widget, and we are going to have pretty interface
What do you think?
More information about the Alsa-devel