[alsa-devel] [RFC 2/2] ASoC: tlv320dac33: Request for reordered update power sequence
peter.ujfalusi at nokia.com
Thu Dec 2 13:52:04 CET 2010
On Thursday 02 December 2010 14:24:23 ext Mark Brown wrote:
> On Thu, Dec 02, 2010 at 02:03:10PM +0200, Peter Ujfalusi wrote:
> > + codec->dapm.dapm_reorder_pupdate = 1;
I'm really bad at naming for sure.
> Sorry, meant to say on the previous patch: it's also not ideal that this
> affects all widgets on the CODEC, it means that this is an all or
> nothing change which isn't ideal.
That was my intention to have the ability set this reordered mode for the codec.
Back to the naming.. What about reorder_dapm_update_power, and move the flag to
the snd_soc_dapm_widget struct?
I could think two ways of moving this per widget config:
Either add new widgets:
SND_SOC_DAPM_REORDERED_SWITCH, and SND_SOC_DAPM_REORDERED_SWITCH_E, which will
have the same list of parameters, but sets the reorder_dapm_update_power flag
for the widget.
But the widget names looks terible.
Or have a helper function, which can set this flag for the given widget,
snd_soc_dapm_set_update_power_reordering(struct snd_soc_codec *codec, const char
It will find the widget, and sets the flag for that widget only.
The function name again looks bad.
More information about the Alsa-devel