[alsa-devel] Mic stops working after installation (ALC861)

remrot at gmail.com remrot at gmail.com
Fri Sep 25 13:04:10 CEST 2009

I've done some more tests and collected a lot of data. And I found a
workaround for the problem: adding "position_fix=1" reactivates the mic! Now
I have sound and a working mic! However, there are some downsides:

First of all, the recording quality is much lower than within the live
session. I need to set the volume of the capture device to max to be able to
recognize my own voice, but that introduces a lot of noise to the recorded
stream. Within a live session, the recorded stream is much louder, it is
usable even with the capture device almost muted! I totally don't understand
how this can happen...

Secondly, I still consider it a bug when something works within the live
system and stops working after installation! This is kind of a
"sound-lottery" and would easily become a show-stopper for less experienced
users. To find the reason for the bug, I collected data from different
settings and compared them, without a result. However, I'm not an ALSA
developer, so I decided to attach all collected information hoping that it
will be helpful. These are the files inside the archive:

alsa-info-live.txt : information collected from the alsa-info script within
the live session (everything worked perfectly)
alsa-info-installed.txt : info collected after installation, with no
additional options (nothing worked, 1 out of 10 times the sound worked)
alsa-info-probe.txt : dito, but with 'probe_mask=8' (sound works, mic is
alsa-info-pos.txt : dito, but with  'position_fix=1' (sound and mic work,
but low quality)

I don't know for how long I'll have access to this machine, but as long as I
do, I can carry out additional tests and collect more data if necc.



2009/9/24 <remrot at gmail.com>

> /* Sorry for posting this to the devel list, but the problem seems to be
> trickier than I first thought *
> *  and I don't have much time left to fix it (not my machine)! Thanks...
>                                     */
> Hi!
>  I've got a very strange problem with a ALC861 soundchip on a friend's
> Toshiba A100-507 Laptop. Sound output and input work perfectly within a live
> session using the Ubuntu Jaunty and Karmic (Alpha6) CDs but immediately
> stops working after installing the system. Currently I've installed the
> latest Karmic containing kernel 2.6.31 and ALSA 1.0.20. I've attached the
> output of the alsa-info script as well as the output of 'pacmd list' for
> both systems (live and installed).
>  Right after the installation the sound stopped working and I couldn't
> record anything. Alsamixer showed only output devices, no capture devices at
> all (everything has been correct within the live session). In 'dmesg' I
> found the following error messages:
> [  279.924019] hda-intel: azx_get_response timeout, switching to polling
> mode: last cmd=0x301f000a
> [  280.928019] hda_intel: azx_get_response timeout, switching to single_cmd
> mode: last cmd=0x301f000a
> After doing some research I found this guide (thx Mr. Iwai):
> http://www.kernel.org/pub/linux/kernel/people/tiwai/docs/HD-Audio.html#_codec_probing_problem
> And indeed, adding 'probe_mask=8' fixed the sound output and brought back
> the capture devices (remember that they were there within the live session
> without that option). I've also tried the 'model=toshiba' option (combined
> with
> 'probe_mask' and standalone) but that didn't help at all (no capture
> devices and no sound).
> The current situation:
>  I've already posted to the PulseAudio mailing ist and got some help from
> Mr. Colin Guthrie but we haven't found a solution (everything seems OK
> regarding PA). I still can't record anything within the installed system. I
> tried audacity, alsarec and the gnome-sound-recorder without luck. When
> recording in audacity, the timeline cursor doesn't move, it only flickers.
> In gnome-recorder, recording stops right after it has started and the
> application hangs on exit. PA's volume meter doesn't show anything either,
> it is empty. I compared the configurations on both systems but I see no
> differences that are not related to the 'probe_mask' option... I really
> believe that there is a solution because everything works in a live session.
> Can anybody help me with this?
> Regards
> JK
-------------- next part --------------
A non-text attachment was scrubbed...
Name: alsa_info.tar.gz
Type: application/x-gzip
Size: 6529 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20090925/b65d0924/attachment.gz 

More information about the Alsa-devel mailing list