[alsa-devel] Mic stops working after installation (ALC861)

remrot at gmail.com remrot at gmail.com
Thu Sep 24 15:29:33 CEST 2009

/* Sorry for posting this to the devel list, but the problem seems to be
trickier than I first thought *
*  and I don't have much time left to fix it (not my machine)! Thanks...


 I've got a very strange problem with a ALC861 soundchip on a friend's
Toshiba A100-507 Laptop. Sound output and input work perfectly within a live
session using the Ubuntu Jaunty and Karmic (Alpha6) CDs but immediately
stops working after installing the system. Currently I've installed the
latest Karmic containing kernel 2.6.31 and ALSA 1.0.20. I've attached the
output of the alsa-info script as well as the output of 'pacmd list' for
both systems (live and installed).

 Right after the installation the sound stopped working and I couldn't
record anything. Alsamixer showed only output devices, no capture devices at
all (everything has been correct within the live session). In 'dmesg' I
found the following error messages:

[  279.924019] hda-intel: azx_get_response timeout, switching to polling
mode: last cmd=0x301f000a
[  280.928019] hda_intel: azx_get_response timeout, switching to single_cmd
mode: last cmd=0x301f000a

After doing some research I found this guide (thx Mr. Iwai):

And indeed, adding 'probe_mask=8' fixed the sound output and brought back
the capture devices (remember that they were there within the live session
without that option). I've also tried the 'model=toshiba' option (combined
'probe_mask' and standalone) but that didn't help at all (no capture devices
and no sound).

The current situation:

 I've already posted to the PulseAudio mailing ist and got some help from
Mr. Colin Guthrie but we haven't found a solution (everything seems OK
regarding PA). I still can't record anything within the installed system. I
tried audacity, alsarec and the gnome-sound-recorder without luck. When
recording in audacity, the timeline cursor doesn't move, it only flickers.
In gnome-recorder, recording stops right after it has started and the
application hangs on exit. PA's volume meter doesn't show anything either,
it is empty. I compared the configurations on both systems but I see no
differences that are not related to the 'probe_mask' option... I really
believe that there is a solution because everything works in a live session.
Can anybody help me with this?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: files.tar.gz
Type: application/x-gzip
Size: 14459 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20090924/88027eec/attachment-0001.gz 

More information about the Alsa-devel mailing list