[alsa-devel] alsa-utils cross compilation error

Jaroslav Kysela perex at perex.cz
Tue Oct 6 16:21:59 CEST 2009

On Tue, 6 Oct 2009, Harish Kumar wrote:

> Hi,
> I am trying to cross compile the alsa utils for PPC and as well as arm
> architecture. the compilation of alsa-libs was successful with their
> respective toolchains. But configuring the alsa-util is failing. I am
> using alsa-utils-1.0.11rc2,alsa-lib-1.0.11rc2.  I am getting the error
> checking for libasound headers version >= 1.0.9... not present.
> configure: error: Sufficiently new version of libasound not found. I
> feel i have to provide the path of the include files but not sure
> which path to be passed and how it needs to be passed to configure.

# ./configure --help | grep alsa | grep prefix
   --with-alsa-prefix=PFX  Prefix where Alsa library is installed(optional)
   --with-alsa-inc-prefix=PFX  Prefix where include libraries are (optional)


Jaroslav Kysela <perex at perex.cz>
Linux Kernel Sound Maintainer
ALSA Project, Red Hat, Inc.

More information about the Alsa-devel mailing list