[alsa-devel] [PATCH 1/1 - try2] ASoC: add support for multiple cards/codecs in debugfs
broonie at opensource.wolfsonmicro.com
Thu Oct 1 13:09:19 CEST 2009
On Thu, Oct 01, 2009 at 02:02:04PM +0300, Peter Ujfalusi wrote:
> On Thursday 01 October 2009 13:51:07 ext Mark Brown wrote:
> > I'd rather use dev_name() for the CODEC itself if possible, that is more
> > likely to be stable going forward and one of the immediate aims with the
> > API refactoring is to remove socdev entirely at runtime.
> At this point the codec->dev was NULL, that is why I have used the socdev->dev
Right, your CODEC driver needs updating to current APIs. Omitting the
device name is a good fallback here since you won't be able to have more
than one of the same device anyway if a device isn't provided.
> > > ret = snd_pcm_hw_constraint_minmax(substream->runtime,
> > but this doesn't seem to accomplish that goal? I can't actually spot
> > the difference either, I'm assuming it's just whitespace? If so I'll
> > apply as-is.
> It is my editor, which removed the tailing space from that line, I have
> mentioned it in the intro mail.
Oh, right. Like I was saying yesterday it's better to not use a
separate cover letter for single patches.
More information about the Alsa-devel