[alsa-devel] No sound with nVidia Corporation MCP79 High Definition Audio (rev b1) (Macbook Pro 5, 5)

Takashi Iwai tiwai at suse.de
Mon Jun 29 09:24:42 CEST 2009

At Sat, 27 Jun 2009 03:16:54 +0200,
Andreas Nuesslein wrote:
> I just got a macbookpro (mid2009 version) with a new nvidia chipset.
> there is no sound at all. neither via the built-in speakers nor via
> out-jack.
> i tried aplay -D myfile.wav with everything from aplay -L  as well.
> i also tried a recent snapshot (alsa-driver-20090626.tar.bz2) as well
> as gentoo ebuilds alsa-headers-9999 and alsa-driver-9999 (which uses
> git to pull recent versions).
> so here's a little information i can gather:
> $ lspci -s 00:08.0 -v
> 00:08.0 Audio device: nVidia Corporation MCP79 High Definition Audio
> (rev b1) Subsystem: nVidia Corporation Device cb79
>         Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
>         Memory at d3480000 (32-bit, non-prefetchable) [size=16K]
>         Capabilities: <access denied>
>         Kernel driver in use: HDA Intel
>         Kernel modules: snd-hda-intel
> alsa-info:
> http://www.alsa-project.org/db/?f=80e89b82fec184b68a88b9ed4128544a276775fc

Interesting.  This is really an unknown codec chip (1013:4206).
Which vendor/product of the codec chip is this?
(Oh, it's a Mac.  So Apple won't say anything specific?)


More information about the Alsa-devel mailing list