[alsa-devel] No sound with nVidia Corporation MCP79 High Definition Audio (rev b1) (Macbook Pro 5, 5)

Andreas Nuesslein nutz at unfoog.de
Sat Jun 27 03:16:54 CEST 2009

I just got a macbookpro (mid2009 version) with a new nvidia chipset.

there is no sound at all. neither via the built-in speakers nor via

i tried aplay -D myfile.wav with everything from aplay -L  as well.

i also tried a recent snapshot (alsa-driver-20090626.tar.bz2) as well
as gentoo ebuilds alsa-headers-9999 and alsa-driver-9999 (which uses
git to pull recent versions).

so here's a little information i can gather:

$ lspci -s 00:08.0 -v
00:08.0 Audio device: nVidia Corporation MCP79 High Definition Audio
(rev b1) Subsystem: nVidia Corporation Device cb79
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
        Memory at d3480000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel


modinfo snd-hda-intel:

i also found a thread about that problem (w/o solution obviously):


hope that's all information necessary.

if i can i'd love to help in some way.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20090627/1ade406c/attachment.sig 

More information about the Alsa-devel mailing list