[alsa-devel] hda-intel on macbook5, 1 (was: lockdep warning on 2.6.29-rc1 with pulseaudio)

Takashi Iwai tiwai at suse.de
Wed Jan 14 11:46:28 CET 2009

At Wed, 14 Jan 2009 11:19:08 +0100,
Johannes Berg wrote:
> > > I've tried googling for this macbook 5,1 (13.3") issue, and have found
> > > various information, some people claim it should work, but it doesn't
> > > seem to for me with the same software versions...
> > 
> > Did you try some model options?  For example, model=macpro, model=mbp3,
> > or model=imac24.
> Yes, I'm not sure which ones I tried, so I just went back and tried
> these, no help. The optical output lights up when I enable it, but I
> have no way to check if anything is modulated onto it. Your initial
> comment seems to make sense, some GPIO line that controls the PA is
> maybe not enabled? Unfortunately Apple hasn't published their driver as
> open source, afaict.

You can try GPIO setup via hda-verb program.

For example,
	hda-verb /dev/snd/hwC0D0 1 SET_GPIO_MASK 3
	hda-verb /dev/snd/hwC0D0 1 SET_GPIO_DIR 3
	hda-verb /dev/snd/hwC0D0 1 SET_GPIO_DATA 3
will set GPIO#0 and #1 to 1.

Try the above first without model option.

BTW, looking at your alsa-info output, all volumes are quite low.
Try to raise more.


More information about the Alsa-devel mailing list